site counter installation problems - help!
Goto page Previous  1, 2
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.   printer-friendly view    phpMiX.org Forum Index -> mxBB Modules -> mxBB Module: mx_sitestats
View previous topic :: View next topic  
Author Message
cryptoknight
Apprentice
Apprentice


Joined: 18 Sep 2004
Posts: 16

PostPosted: Mon Apr 11, 2005 8:19 pm    Post subject: Re: site counter installation problems - help! Reply with quote

No worries... whatever the problem was... it was a pl3 problem... pl4 has fixed it... 
Back to top
View user's profile Send private message
markus
[Administrator]
[Administrator]


Joined: 28 Jul 2003
Posts: 1124

PostPosted: Mon Apr 11, 2005 8:37 pm    Post subject: Re: site counter installation problems - help! Reply with quote

...this is really strange. Only the mxBB Installer has been updated between pl3 and pl4. Shocked
http://sourceforge.net/mailarchive/forum.php?thread_id=7013394&forum_id=44450 <- pl4
http://sourceforge.net/mailarchive/forum.php?thread_id=6999276&forum_id=44450 <- pl3

Maybe it was a problem with file permissions or some file truncated while uploading.... Confused

Anyway, glad to see it has been sorted.

 
 
_________________
http://www.phpmix.org
 
Back to top
View user's profile Send private message
cryptoknight
Apprentice
Apprentice


Joined: 18 Sep 2004
Posts: 16

PostPosted: Mon Apr 11, 2005 8:46 pm    Post subject: Re: site counter installation problems - help! Reply with quote

It worked for about an hour or so... then went right back where it was... 
Back to top
View user's profile Send private message
cryptoknight
Apprentice
Apprentice


Joined: 18 Sep 2004
Posts: 16

PostPosted: Mon Apr 11, 2005 9:22 pm    Post subject: Re: site counter installation problems - help! Reply with quote

And if I could figure out a way to leave it in there so you could check it...without disabling my site...I would.

It's almost like it's an infinite loop or somesuch.
 
Back to top
View user's profile Send private message
markus
[Administrator]
[Administrator]


Joined: 28 Jul 2003
Posts: 1124

PostPosted: Mon Apr 11, 2005 9:52 pm    Post subject: Re: site counter installation problems - help! Reply with quote

hmmm... try this:

OPEN: modules/mx_sitestats/includes/common.php

FIND:
Code:
@session_start();


REPLACE WITH:
Code:
// @session_start();


Question

 
 
_________________
http://www.phpmix.org
 
Back to top
View user's profile Send private message
cryptoknight
Apprentice
Apprentice


Joined: 18 Sep 2004
Posts: 16

PostPosted: Mon Apr 11, 2005 10:16 pm    Post subject: Re: site counter installation problems - help! Reply with quote

That fixed it...

the next question... is what does that mean?
 
Back to top
View user's profile Send private message
markus
[Administrator]
[Administrator]


Joined: 28 Jul 2003
Posts: 1124

PostPosted: Mon Apr 11, 2005 10:35 pm    Post subject: Re: site counter installation problems - help! Reply with quote

TBH, I don't know. It is strange it happens since you upgraded.


Now, if you find your session counter increments for every page hit, even from the same session, then try to add that line on top of your mx/common.php file. That's is before any other HTTP headers have been sent to the browser.


...or set the PHP setting session.auto_start to ON. You can do this by adding the following line to your .htaccess file:

Code:
php_flag   session.auto_start    on

 
 
_________________
http://www.phpmix.org
 
Back to top
View user's profile Send private message
cryptoknight
Apprentice
Apprentice


Joined: 18 Sep 2004
Posts: 16

PostPosted: Mon Apr 11, 2005 10:46 pm    Post subject: Re: site counter installation problems - help! Reply with quote

Adding in the php flag to .htaccess works fine as well... *scratches head* 
Back to top
View user's profile Send private message
found
Apprentice
Apprentice


Joined: 02 Mar 2005
Posts: 5
Location: Edmonton AB Canada

PostPosted: Sat Apr 16, 2005 9:58 pm    Post subject: Re: site counter installation problems - help! Reply with quote

Awesome, I am having the same difficulties my portals and I thought it was from my move from my development server to the live server.

Foolish me thinking it was an MX issue I reported some of this on the MX site Mennonite Hobbit tried to help. I gave up and I just removed the code.

The only difference I noticed in the server setups was the mysql version.

Now, when I find the time, I will try these fixes and see how far I get. I post my results here.

Thank You folks! phpMix Rocks!
 
Back to top
View user's profile Send private message Visit poster's website
found
Apprentice
Apprentice


Joined: 02 Mar 2005
Posts: 5
Location: Edmonton AB Canada

PostPosted: Mon May 02, 2005 4:38 am    Post subject: Re: site counter installation problems - help! Reply with quote

markus wrote:
TBH, I don't know. It is strange it happens since you upgraded.


Now, if you find your session counter increments for every page hit, even from the same session, then try to add that line on top of your mx/common.php file. That's is before any other HTTP headers have been sent to the browser.


...or set the PHP setting session.auto_start to ON. You can do this by adding the following line to your .htaccess file:

Code:
php_flag   session.auto_start    on


Laughing Worked Like a charm on both of the sites I look after.

Thanks Markus you Rock dude!
 
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.   printer-friendly view    phpMiX.org Forum Index -> mxBB Modules -> mxBB Module: mx_sitestats All times are GMT + 1 Hour
Goto page Previous  1, 2
Page 2 of 2


 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum