Select and expand do not appear
 
 
Post new topic   Reply to topic   printer-friendly view    phpMiX.org Forum Index -> phpBB MODs -> Select Expand BBCodes
View previous topic :: View next topic  
Author Message
Jean-guy
Starter
Starter


Joined: 02 Jun 2006
Posts: 4

PostPosted: Fri Jun 02, 2006 1:07 pm    Post subject: Select and expand do not appear Reply with quote

Hi all,
Just installed this mod, but nothing appears just next to QUOTE or CODE.
I am wondering if something need to be edited in the JS file ?
I have the CH installed, but didn't encounter any problem to edit all the files and to add everything needed for this mod. What the problem can be ?

Please help
Thanks in advance
 
Back to top
View user's profile Send private message
markus
[Administrator]
[Administrator]


Joined: 28 Jul 2003
Posts: 1124

PostPosted: Sat Jun 03, 2006 11:13 am    Post subject: Re: Select and expand do not appear Reply with quote

Hi,

I'm not aware of any problems with this MOD and Categories Hierarchy MOD. On the other hand, there have been reported issues with some themes or conflicts with other javascripts installed on the same page. Try browsing this forum, maybe a previous report can help you?

Jean-guy wrote:
I am wondering if something need to be edited in the JS file ?

No, the javascript file doesn't need to be touched. The problem might be with the changes made to bbcode.tpl or if the same page has another javascript code that breaks this MOD.

To isolate problems with themes, please try making sure it works on subSilver.

To isolate problems with other javascripts, please try disabling all other javascripts and then add one by one, so the cause can be found easily.

 
 
_________________
http://www.phpmix.org
 
Back to top
View user's profile Send private message
Jean-guy
Starter
Starter


Joined: 02 Jun 2006
Posts: 4

PostPosted: Sat Jun 03, 2006 11:28 am    Post subject: Reply with quote

There is indeed others script in the bbcode.tpl, I do not have the subsilver them altough. Do you see anything wrong, or that I can modify to allow both working ?

Code:
<!-- BEGIN ulist_open --><ul><!-- END ulist_open -->
<!-- BEGIN ulist_close --></ul><!-- END ulist_close -->

<!-- BEGIN olist_open --><ol type="{LIST_TYPE}"><!-- END olist_open -->
<!-- BEGIN olist_close --></ol><!-- END olist_close -->

<!-- BEGIN listitem --><li><!-- END listitem -->

<!-- BEGIN quote_username_open --></span>
<table class="bodyline" width="90%" cellspacing="1" cellpadding="3" border="0" align="center">
<tr><td class="helpline"><span class="genmed"><b>{USERNAME} {L_WROTE}:</b>

<script type="text/javascript" src="{U_SXBB_JSLIB}"></script>

<script type="text/javascript">

<!--

   var id = 'SXBB' + (1000 + Math.floor(Math.random() * 5000));

   SXBB[id] = new _SXBB(id);

   SXBB[id].T['select'] = '{L_SELECT}';

   SXBB[id].T['expand'] = '{L_EXPAND}';

   SXBB[id].T['contract'] = '{L_CONTRACT}';

   SXBB[id].writeCmd();

//-->

</script>

      </span></td>

   </tr>

   <tr>

     <td class="quote">

<script type="text/javascript">

<!--

   SXBB[id].writeDiv();

//-->

</script><!-- END quote_username_open -->
<!-- BEGIN quote_open --></span>
<table class="bodyline" width="90%" cellspacing="1" cellpadding="3" border="0" align="center">
<tr>
     <td class="helpline"><span class="genmed"><b>{L_QUOTE}:</b>

<script type="text/javascript" src="{U_SXBB_JSLIB}"></script>

<script type="text/javascript">

<!--

   var id = 'SXBB' + (1000 + Math.floor(Math.random() * 5000));

   SXBB[id] = new _SXBB(id);

   SXBB[id].T['select'] = '{L_SELECT}';

   SXBB[id].T['expand'] = '{L_EXPAND}';

   SXBB[id].T['contract'] = '{L_CONTRACT}';

   SXBB[id].writeCmd();

//-->

</script>

      </span></td>

   </tr>

   <tr>

     <td class="quote">

<script type="text/javascript">

<!--

   SXBB[id].writeDiv();

//-->

</script><!-- END quote_open -->
<!-- BEGIN quote_close -->

<script type="text/javascript">

<!--

   document.write('</div>');

//-->

</script>

      </td>
   </tr>
</table>
<span class="postbody"><!-- END quote_close -->

<!-- BEGIN code_open --></span>
<table class="bodyline" width="90%" cellspacing="1" cellpadding="3" border="0" align="center">
<tr>
     <td class="helpline"><span class="genmed"><b>{L_CODE}:</b>

<script type="text/javascript" src="{U_SXBB_JSLIB}"></script>

<script type="text/javascript">

<!--

   var id = 'SXBB' + (1000 + Math.floor(Math.random() * 5000));

   SXBB[id] = new _SXBB(id);

   SXBB[id].T['select'] = '{L_SELECT}';

   SXBB[id].T['expand'] = '{L_EXPAND}';

   SXBB[id].T['contract'] = '{L_CONTRACT}';

   SXBB[id].writeCmd();

//-->

</script>

      </span></td>

   </tr>

   <tr>

     <td class="code">

<script type="text/javascript">

<!--

   SXBB[id].writeDiv();

//-->

</script><!-- END code_open -->
<!-- BEGIN code_close -->

<script type="text/javascript">

<!--

   document.write('</div>');

//-->

</script>

      </td>
   </tr>
</table>
<span class="postbody"><!-- END code_close -->


<!-- BEGIN b_open --><span style="font-weight: bold"><!-- END b_open -->
<!-- BEGIN b_close --></span><!-- END b_close -->

<!-- BEGIN u_open --><span style="text-decoration: underline"><!-- END u_open -->
<!-- BEGIN u_close --></span><!-- END u_close -->

<!-- BEGIN i_open --><span style="font-style: italic"><!-- END i_open -->
<!-- BEGIN i_close --></span><!-- END i_close -->

<!-- BEGIN color_open --><span style="color: {COLOR}"><!-- END color_open -->
<!-- BEGIN color_close --></span><!-- END color_close -->

<!-- BEGIN size_open --><span style="font-size: {SIZE}px; line-height: normal"><!-- END size_open -->
<!-- BEGIN size_close --></span><!-- END size_close -->

<!-- BEGIN img --><img src="{URL}" border="0" alt="" /><!-- END img -->
<!-- BEGIN fullalbumimg --><a href="album_showpage.php?pic_id={IMG_NUM}" target="_blank" class="postlink"><img src="album_picm.php?pic_id={IMG_NUM}" alt="Image {IMG_NUM}" title="Image {IMG_NUM}" border="0" /></a><!-- END fullalbumimg -->

<!-- BEGIN albumimg --><a href="album_showpage.php?pic_id={IMG_NUM}" target="_blank" class="postlink"><img src="album_thumbnail.php?pic_id={IMG_NUM}" alt="Image {IMG_NUM}" title="Image {IMG_NUM}" border="0" /></a><!-- END albumimg -->

<!-- BEGIN albumimgl --><a href="album_showpage.php?pic_id={IMG_NUM}" target="_blank" class="postlink"><img src="album_thumbnail.php?pic_id={IMG_NUM}" border="0" align="left" alt="Image {IMG_NUM}" title="Image {IMG_NUM}" /></a><!-- END albumimgl -->

<!-- BEGIN albumimgr --><a href="album_showpage.php?pic_id={IMG_NUM}" target="_blank" class="postlink"><img src="album_thumbnail.php?pic_id={IMG_NUM}" border="0" align="right" alt="Image {IMG_NUM}" title="Image {IMG_NUM}" /></a><!-- END albumimgr -->

<!-- BEGIN albumimgc --><center><a href="album_showpage.php?pic_id={IMG_NUM}" target="_blank" class="postlink"><img src="album_thumbnail.php?pic_id={IMG_NUM}" border="0" align="center" alt="Image {IMG_NUM}" title="Image {IMG_NUM}" /></a></center><!-- END albumimgc -->
<!-- BEGIN url --><a href="{URL}" target="_blank" class="postlink">{DESCRIPTION}</a><!-- END url -->

<!-- BEGIN email --><a href="mailto:{EMAIL}">{EMAIL}</a><!-- END email -->
 
Back to top
View user's profile Send private message
markus
[Administrator]
[Administrator]


Joined: 28 Jul 2003
Posts: 1124

PostPosted: Sat Jun 03, 2006 11:47 am    Post subject: Reply with quote

At a first sight, your file bbcode.tpl looks ok.

The problem might come from other javascripts running when you visit viewtopic.php

Do you see any javascript errors?
Do you see onload="something" in your BODY tag?

 
 
_________________
http://www.phpmix.org
 
Back to top
View user's profile Send private message
Jean-guy
Starter
Starter


Joined: 02 Jun 2006
Posts: 4

PostPosted: Sat Jun 03, 2006 12:21 pm    Post subject: Reply with quote

the only script I have in the viewtopic_body is

Code:

<script language="JavaScript" type="text/javascript"><!--//
function _icq()
{
   this.ids = new Array();
   return this;
}
   _icq.prototype.objref = function(id)
   {
      return document.getElementById ? document.getElementById(id) : (document.all ? document.all[id] : (document.layers ? document.layers[id] : null));
   }
   _icq.prototype.display_status = function()
   {
      if ( (navigator.userAgent.toLowerCase().indexOf('mozilla') == -1) || (navigator.userAgent.indexOf('5.') != -1) || (navigator.userAgent.indexOf('6.') != -1) )
      {
         for ( i = 1; i < this.ids.length; i++ )
         {
            icq_status = this.objref(this.ids[i]);
            if ( icq_status && icq_status.style )
            {
               icq_status.style.display = '';
            }
         }
      }
   }

icq_status = new _icq();
icq_status.ids = Array(''<!-- BEGIN postrow --><!-- BEGIN icq -->, 'icq_status_{postrow.U_POST_ID}'<!-- END icq --><!-- END postrow -->);
icq_status.display_status();
//--></script>


I suppose it is intended to launch some icq related stuff ... i do not have really the need of it. Could it be the problem ?
 
Back to top
View user's profile Send private message
markus
[Administrator]
[Administrator]


Joined: 28 Jul 2003
Posts: 1124

PostPosted: Sat Jun 03, 2006 1:25 pm    Post subject: Reply with quote

That piece of javascript doens't look like the source of the problem either.

Try installing subSilver. You could hide it to your users with Admin Templates MOD... or, IIRC, eXtreme Styles MOD has also this feature.

It is good to have subSilver there, all MODs are based on that theme. So that makes it easy to isolate problems.

 
 
_________________
http://www.phpmix.org
 
Back to top
View user's profile Send private message
Jean-guy
Starter
Starter


Joined: 02 Jun 2006
Posts: 4

PostPosted: Sat Jun 03, 2006 8:35 pm    Post subject: Reply with quote

ok guys
my fault, my fault my fault, working perfectly ...

I put the JS file in the theme directory instead of his parent Template Embarassed

Thanks for support and your time.
 
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic   printer-friendly view    phpMiX.org Forum Index -> phpBB MODs -> Select Expand BBCodes All times are GMT + 1 Hour
 
Page 1 of 1


 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum