Problem with 1.31 (upgrading from 1.2.0)
Goto page Previous  1, 2
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.   printer-friendly view    phpMiX.org Forum Index -> mxBB Modules -> mxBB Module: mx_sitestats
View previous topic :: View next topic  
Author Message
markus
[Administrator]
[Administrator]


Joined: 28 Jul 2003
Posts: 1124

PostPosted: Fri Jul 16, 2004 11:52 pm    Post subject: Re: Problem with 1.31 (upgrading from 1.2.0) Reply with quote

just use one of those lines and set it up upon your system, which seems ok as you did.

too late, true. Only if days has 48h....


Razz

 
 
_________________
http://www.phpmix.org
 
Back to top
View user's profile Send private message
markus
[Administrator]
[Administrator]


Joined: 28 Jul 2003
Posts: 1124

PostPosted: Fri Jul 16, 2004 11:57 pm    Post subject: Re: Problem with 1.31 (upgrading from 1.2.0) Reply with quote

Updated release notes like this:

Code:
// ------------------------------
// MOD:mx_sitestats:begin
//
// Select one of the following lines (or edit) to match relative path to your mx root !!!
$mx_root_path = '../portal/';
$mx_root_path = '../';

include_once( $mx_root_path . 'modules/mx_sitestats/collector.' . $phpEx );
//
//MOD:mx_sitestats:end
// ------------------------------


Seems better? ...or? Embarassed

 
 
_________________
http://www.phpmix.org
 
Back to top
View user's profile Send private message
Flash
Junior Member
Junior Member


Joined: 03 May 2004
Posts: 29
Location: Vxj, Sweden

PostPosted: Sat Jul 17, 2004 12:21 am    Post subject: Re: Problem with 1.31 (upgrading from 1.2.0) Reply with quote

JIHAAAAAA!!!!!

everything seems to work now. I Will have a question mark for the "Top Referers" though. Can see the url in ACP but not under stats. I don't know what to do under the link "Referers Management".

Any docs for that page?


thx for all help, I will explain tomorrow (today) Smile what I did to remove the stat options in the dropdown menu. The options where there even after I had deleted the module.

http://liteportal.no-ip.com/index.php?page=10

 
 
_________________
/Flash
http://www.rfactor.se
 
Back to top
View user's profile Send private message Visit poster's website
markus
[Administrator]
[Administrator]


Joined: 28 Jul 2003
Posts: 1124

PostPosted: Sat Jul 17, 2004 11:05 am    Post subject: Re: Problem with 1.31 (upgrading from 1.2.0) Reply with quote

Flash wrote:
Can see the url in ACP but not under stats. I don't know what to do under the link "Referers Management".

Any docs for that page?

In fact, there is something in the release notes.
http://forums.phpmix.org/viewtopic.php?t=29#TOP_REFERERS

That page allows you to manage HTTP Referers stored in your database (by the Collector installed as a MOD in both page_header.php).

I'm going to add a couple of additional notes ASAP, though.


Flash wrote:
thx for all help, I will explain tomorrow (today) Smile what I did to remove the stat options in the dropdown menu. The options where there even after I had deleted the module.
Question


Flash wrote:
http://liteportal.no-ip.com/index.php?page=10
Quote:
Sorry, but you don't have privilege to access this page.
Question
 
 
_________________
http://www.phpmix.org
 
Back to top
View user's profile Send private message
markus
[Administrator]
[Administrator]


Joined: 28 Jul 2003
Posts: 1124

PostPosted: Sat Jul 17, 2004 12:13 pm    Post subject: Re: Problem with 1.31 (upgrading from 1.2.0) Reply with quote

markus_petrux wrote:
In fact, there is something in the release notes.
http://forums.phpmix.org/viewtopic.php?t=29#TOP_REFERERS

That page allows you to manage HTTP Referers stored in your database (by the Collector installed as a MOD in both page_header.php).

I'm going to add a couple of additional notes ASAP, though.


DONE!

http://forums.phpmix.org/viewtopic.php?t=29#TOP_REFERERS

Rolling Eyes

 
 
_________________
http://www.phpmix.org
 
Back to top
View user's profile Send private message
Flash
Junior Member
Junior Member


Joined: 03 May 2004
Posts: 29
Location: Vxj, Sweden

PostPosted: Sat Jul 17, 2004 12:33 pm    Post subject: Re: Problem with 1.31 (upgrading from 1.2.0) Reply with quote

Flash wrote:
thx for all help, I will explain tomorrow (today) Smile what I did to remove the stat options in the dropdown menu. The options where there even after I had deleted the module.
Question

The problem here was that I had double options in "Block Administration" too after I had installed the module. When I deleted the mod all blocks for the statmod disapeard in "Block Administration". I installed it again I got double options for the blocks for the module, hmmm.

So I finally installed the mod again and deleted all blocks in "Block Administration" and then deleted the module in "Module Administration". Then I installed the statmodule again and then it worked. Only one option, that even fixed another problem Smile
I checked again with Objects Integrity Check today and here is the result: http://liteportal.no-ip.com/temp/statprob4.jpg


Flash wrote:
http://liteportal.no-ip.com/index.php?page=10
Quote:
Sorry, but you don't have privilege to access this page.
Question

Now you can see the stats Smile Rolling Eyes

 
 
_________________
/Flash
http://www.rfactor.se
 
Back to top
View user's profile Send private message Visit poster's website
markus
[Administrator]
[Administrator]


Joined: 28 Jul 2003
Posts: 1124

PostPosted: Sat Jul 17, 2004 1:46 pm    Post subject: Re: Problem with 1.31 (upgrading from 1.2.0) Reply with quote

Flash wrote:
The problem here was that I had double options in "Block Administration" too after I had installed the module. When I deleted the mod all blocks for the statmod disapeard in "Block Administration". I installed it again I got double options for the blocks for the module, hmmm.

That seems a Bug in the MX AdminCP itself. It should do delete operations in cascade (ie. delete all affected children).

As an example of what I'm trying to mean:

If you want to delete a module, MX should do:
  1. Delete the module (table mx_module).
  2. Delete all functions/blocks of that module (tables mx_function and mx_block).
  3. Delete all parameters of those functions/blocks (tables mx_parameter, mx_parameter_option and mx_block_system_parameter).
  4. Delete all blocks associated to page columns (table mx_column_block).

It seems MX forgot step (4), so that should be reported as a Bug at MX site, I believe.

Confused

Flash wrote:
So I finally installed the mod again and deleted all blocks in "Block Administration" and then deleted the module in "Module Administration". Then I installed the statmodule again and then it worked. Only one option, that even fixed another problem Smile
I checked again with Objects Integrity Check today and here is the result: http://liteportal.no-ip.com/temp/statprob4.jpg

I coded that AdminCP addon some time ago. Glad it has been of some help here.


Flash wrote:
Flash wrote:
http://liteportal.no-ip.com/index.php?page=10
Quote:
Sorry, but you don't have privilege to access this page.
Question

Now you can see the stats Smile Rolling Eyes

Now, you have a new HTTP referer in your database. Wink
Nice theme, btw. Smile

You can remove public access to that page if you wish.


Cheers

 
 
_________________
http://www.phpmix.org
 
Back to top
View user's profile Send private message
Flash
Junior Member
Junior Member


Joined: 03 May 2004
Posts: 29
Location: Vxj, Sweden

PostPosted: Sat Jul 17, 2004 4:28 pm    Post subject: Re: Problem with 1.31 (upgrading from 1.2.0) Reply with quote

markus_petrux wrote:

You can remove public access to that page if you wish.
Cheers


I will do that ...

once again thx for all the help :eusa_clap:

 
 
_________________
/Flash
http://www.rfactor.se
 
Back to top
View user's profile Send private message Visit poster's website
markus
[Administrator]
[Administrator]


Joined: 28 Jul 2003
Posts: 1124

PostPosted: Sat Jul 17, 2004 6:58 pm    Post subject: Re: Problem with 1.31 (upgrading from 1.2.0) Reply with quote

+



:eusa_dance: Wink

 
 
_________________
http://www.phpmix.org
 
Back to top
View user's profile Send private message
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.   printer-friendly view    phpMiX.org Forum Index -> mxBB Modules -> mxBB Module: mx_sitestats All times are GMT + 1 Hour
Goto page Previous  1, 2
Page 2 of 2


 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum